rein / aapklok-esp12e
De aapklok firmware voor de versie met ESP12E (main cpu) en Arduino (ledstring controller)

Ledstring displays wrong time and wrong colors #1

Closed rein opened this issue on 11 Jan - 3 comments

rein commented on 11 Jan

Ledstring time and colors are sometimes changing to a bogus value.
(Communication between Arduino and ESP is not stable)

rein commented on 11 Jan

Problem:
Serial data is sent correctly by ESP but is not always the same as data received by Arduino.

Caused by:
The Arduino is working with 5V and the ESP is working with 3.5V.
A diode is place beween Esp (TX) and Arduino (RX) to make sure the Arduino cannot blow-up the ESP due to different voltage levels.
Maybe this diode is not the right value or a proper solution at all.

Solution:
We have to research a more reliable solution. There are multiple options:
-Use a standard level converter
-Use a better diode
-Use something else

rein commented on 21 Jan

Problem can be solved by removing the diode and connecting ESP-TX to Arduino-RX directly.
Make sure -Arduino RX is defined as INPUT and ESP-TX is defined as OUTPUT else you can blow up the ESP by feeding it 5V from Arduino -RX

rein commented on 21 Jan

Needs some more testing before closing this issue.

rein closed this issue on 21 Jan
Labels

Priority
highest
Milestone
AAPKLOK 1.0
Assignee
rein
1 participant